Login

NebulaMan / Setups Mac OSX support

Additional software tools

Re: NebulaMan / Setups Mac OSX support

Postby FrankydT » Fri Oct 04, 2013 2:23 am

Thanks,
I've tried it. But not working here.
It crashes immediately when I attempt to open it. (Crash on load)
If other people are running fine on 10.8.5, maybe it's an application conflict (It could be Little Snitch, Tinkertool System, anything)
To find it out, and limit possibilities,
I'll make a fresh reinstall of 10.8.5, check permissions, then I'll install Nebula 1.3.600 Server, and finally Nebula Setups.
If it will run fine, I'll try installing 1.3.602. (I'll try this on 10.6.8 too)
Then I'll try installing other applications one by one

In case of problems I'll let you know and I'll send you the Apple crash Report.
FrankydT
User Level XI
User Level XI
 
Posts: 166
Joined: Tue Dec 28, 2010 3:47 pm

Re: NebulaMan / Setups Mac OSX support

Postby zabukowski » Fri Oct 04, 2013 11:56 am

Sorry to hear about crashes, there is something strange going on :?

I've upgraded my MacBook from 10.6.8 to 10.8.5 and all programs runs without issues.

FrankydT, thanks a lot for your help, really appreciated! Looking forward to see your results with a clean install.

I will perform a clean 10.8.5 install on external disk as well - maybe there is something on my upgraded system, which is required for programs to run successfuly (i can't imagine what, though).

Zabukowski
User avatar
zabukowski
Expert
Expert
 
Posts: 1104
Joined: Sun Mar 28, 2010 8:44 pm
Location: Ljubljana, Slovenia

Re: NebulaMan / Setups Mac OSX support

Postby FrankydT » Sat Oct 05, 2013 8:26 am

Hi,
I've tried reinstalling ML 10.8.5 from scratch.
Installed only Nebula, Nebulaman, Nebula Setups, Reaper and RME Fireface driver

The only version here working fine is Nebula Pro Pro 1.3.600 but if I upgrade to Server (ANY version, 1.3.502, 1.3.505, 1.3.600, 1.3.602) Nebulaman and Setups crash immediately

If I trash preferences and Zabukowski folder in User/Library/Application Support, the FIRST TIME Nebulaman works.
It displays the message AQUA initialization error (The usual message of when it's cleanly installed), I set the usual preferences (Buffer, xml) then it crashes.
I think it's the preference file, if I'm wrong it's layout or nmsettings.
I think Nebulaman and Setups are not compatible with server, when they save/load/create these files they crash

Thank you for the assistance

Here's the Crash Report, you need the preference file too?
Attachments
Nebulaman Crash Report.rtf
(37.6 KiB) Downloaded 58 times
FrankydT
User Level XI
User Level XI
 
Posts: 166
Joined: Tue Dec 28, 2010 3:47 pm

Re: NebulaMan / Setups Mac OSX support

Postby zabukowski » Sat Oct 05, 2013 9:37 am

Crash definitively happens with ACQUA/Nebula initialization - out of my control. If ACQUA is not initialized (first start), then program works. Looks like current ACQUA (1.3.504), 10.8.5 and Nebula Server are no go at the moment.

Strangely, I think Cpwade reported working config 10.8.4 and server.

Can you try to select xml config file, which is installed with PRO (delete setups preferences first)?

I will provide test build with the latest ACQUA (1.3.602) ASAP to see if crashes persist.

Thanks for your help!
Zabukowski
User avatar
zabukowski
Expert
Expert
 
Posts: 1104
Joined: Sun Mar 28, 2010 8:44 pm
Location: Ljubljana, Slovenia

Re: NebulaMan / Setups Mac OSX support

Postby FrankydT » Sat Oct 05, 2013 5:10 pm

Do you mean keeping the xml of the working Pro version, and to use this after upgrade to Server?
I'll try just now
FrankydT
User Level XI
User Level XI
 
Posts: 166
Joined: Tue Dec 28, 2010 3:47 pm

Re: NebulaMan / Setups Mac OSX support

Postby FrankydT » Sat Oct 05, 2013 5:25 pm

Okay I've placed the 1.3.600 PRO xml inside Nebulaman (in Content) and upgraded to 1.3.602 Server.
Now it works
Nebula Setups crashes (maybe because it points directly to the Server version)
I think it should work if I could do the trick as Nebulaman
FrankydT
User Level XI
User Level XI
 
Posts: 166
Joined: Tue Dec 28, 2010 3:47 pm

Re: NebulaMan / Setups Mac OSX support

Postby zabukowski » Sat Oct 05, 2013 5:36 pm

Ok, things are moving :)

Looks like ACQUA used with Nebula Setups and NebulaMan crashes when server's xml file is used ...

Here is new build with the new ACQUA 1.3.602. Please download it and replace old version.

http://www.zabukowski.com/software/NebulaSetups2%20(ML).dmg

1. Delete Nebula Setup's preferences
2. run Nebula Setups and select xml file of your choice (you can try to load server's xml file).

Let me know if still crashes ...

I will install server here ASAP ...

Zabukowski
User avatar
zabukowski
Expert
Expert
 
Posts: 1104
Joined: Sun Mar 28, 2010 8:44 pm
Location: Ljubljana, Slovenia

Re: NebulaMan / Setups Mac OSX support

Postby zabukowski » Sat Oct 05, 2013 5:50 pm

CONFIRMED !!!!

Installed 1.3.600 server here - crashing has started.

I will try to find out what in a server's xml file is causing crashes.

Zabukowski
User avatar
zabukowski
Expert
Expert
 
Posts: 1104
Joined: Sun Mar 28, 2010 8:44 pm
Location: Ljubljana, Slovenia

Re: NebulaMan / Setups Mac OSX support

Postby FrankydT » Sat Oct 05, 2013 6:39 pm

Found the issue!
It's a permission problem
You can't fix it with Disk utility
You must open file properties and change permissions from there
If someone has problems with Nebulaman and Nebula Setups 2,
The files to modify are the vst folder, Acustica folder and all the Nebula vst and xml inside of it
Open properties of these files/folder
You'll see there's a locked faulty-lacking group-users with Obtaining... as name

Remove this group/User.
Add yourself and set to read/write
Do this for very file/folder I mentioned
The most important anyway is the VST folder

Good luck!
Last edited by FrankydT on Sat Oct 05, 2013 6:47 pm, edited 1 time in total.
FrankydT
User Level XI
User Level XI
 
Posts: 166
Joined: Tue Dec 28, 2010 3:47 pm

Re: NebulaMan / Setups Mac OSX support

Postby FrankydT » Sat Oct 05, 2013 6:55 pm

I assure you it's working well now here, both Nebula Setups and Nebulaman
But, if you will made use in Nebula Setups of its own xml, the tweaks feature wouldn't lose its functioning?
Now I'll try with the new version of Setups you provided
Thanks!
FrankydT
User Level XI
User Level XI
 
Posts: 166
Joined: Tue Dec 28, 2010 3:47 pm

PreviousNext

Return to Tools

Who is online

Users browsing this forum: No registered users and 7 guests

cron