Login

Nebula 1.3.412 (64-bits version): Initialization fails

Serious issues

Nebula 1.3.412 (64-bits version): Initialization fails

Postby Mercado_Negro » Sat Jun 12, 2010 2:52 am

I just installed the latest update (1.3.412) and it doesn't initialize properly which makes Reaper crash. I noticed it even changed its GUI (as you can see in the image below); I was using the official red skin.

Nebula3 Pro x64 1.3.412
Reaper 3.60 (64-bits)
Windows 7 Ultimate (64-bits)
M-Audio Projectmix I/O Drivers v5.10.0.5058


Image


NOTE: Previous version works fine.
i7 3770k :: Asus P8H77-V LE :: 16Gb DDR3 @1600MHz :: Geforce GT 520 :: OCZ-Vertex 128Gb :: WD Black Series 1Tb and Green Series 1Tb :: F*******e Liquid56 :: REAPER 64bit and StudioOne 64bit (both latest versions) :: Win 10 64bit
User avatar
Mercado_Negro
Beta Tester
Beta Tester
 
Posts: 1353
Joined: Sat Mar 27, 2010 9:30 am

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby Mercado_Negro » Sat Jun 12, 2010 3:49 am

Update: As Giancarlo suggested, I backed my previous 'acoustica' folder up before updating. I overwrote the new Nebula3CoreII64 Reverb.xml and Nebula3CoreII64.dll files with the old ones, deleted the Nebula3CoreII64_installer.xml and Nebula3CoreII64 Reverb_installer.xml files and now it works. I'll investigate further...
i7 3770k :: Asus P8H77-V LE :: 16Gb DDR3 @1600MHz :: Geforce GT 520 :: OCZ-Vertex 128Gb :: WD Black Series 1Tb and Green Series 1Tb :: F*******e Liquid56 :: REAPER 64bit and StudioOne 64bit (both latest versions) :: Win 10 64bit
User avatar
Mercado_Negro
Beta Tester
Beta Tester
 
Posts: 1353
Joined: Sat Mar 27, 2010 9:30 am

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby giancarlo » Sat Jun 12, 2010 7:29 am

I guess you selected the wrong repository before. Compare xml, I guess datapath is different
User avatar
giancarlo
Founder
Founder
 
Posts: 9183
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby Mercado_Negro » Thu Jun 17, 2010 4:15 pm

No, I chose the right path. I think the problem here is renaming. When I installed it for the first time I removed the 'Core64II' part from the files name because Reaper doesn't have separate paths for 64-bits and 32-bits plug-ins in its 64-bits version (you just add both paths, first the 32-bits one and then the 64-bits path so Reaper first scans the 32-bits folder and then if it finds the plug-in again, with the same name, in the 64-bits path, it uses that):

Image

With Reaper, having different file names for 32-bits and 64-bits plug-ins is counterproductive because if you saved FX Chains in Reaper 32-bits and want to use them in Reaper 64-bits it will load the 32-bits plug-in, that's why I renamed all those Nebula files.

Is there any advantage of having different names for plug-ins dlls with other hosts? Maybe we don't need that 'Core64II' part in the dlls and xml files.

P.S.- I just tried 1.3.413 and it doesn't work either.
i7 3770k :: Asus P8H77-V LE :: 16Gb DDR3 @1600MHz :: Geforce GT 520 :: OCZ-Vertex 128Gb :: WD Black Series 1Tb and Green Series 1Tb :: F*******e Liquid56 :: REAPER 64bit and StudioOne 64bit (both latest versions) :: Win 10 64bit
User avatar
Mercado_Negro
Beta Tester
Beta Tester
 
Posts: 1353
Joined: Sat Mar 27, 2010 9:30 am

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby giancarlo » Thu Jun 17, 2010 4:56 pm

the fact it doesnt' work it's not enough. I need a log.
New version should not initialize, so there is something else which is misconfigured. In any case I need a log.
I suppose you have a file named
Nebula3CoreII64 Reverb.xml
in your folder

if you renamed your previous xml, you can't upgrade. Or you should rename the new vst again before launching.
User avatar
giancarlo
Founder
Founder
 
Posts: 9183
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby Mercado_Negro » Thu Jun 17, 2010 5:12 pm

Please explain to me how I can give you a log. I'll do it right away.

I don't have a "Nebula3CoreII64 Reverb.xml" file in my acustica folder because I renamed it to "Nebula3 Reverb.xml" when I installed it for the first time. When I did the upgrade to 1.3.412 I ended up with new files in that folder which is OK, I just deleted my old files and renamed the new ones. I did the same this morning when I upgraded to 1.3.413. It didn't work in none of these cases (I had to use my old "Nebula3 Reverb.xml" file to make it work).

EDIT: Ok, I finally made it work. This is what I did.

1) I renamed all my files in the acustica folder to:

Nebula3CoreII64 Reverb.dll
Nebula3CoreII64 Reverb.xml
Nebula3CoreII64.dll
Nebula3CoreII64.xml

2) I ran the update to 1.3.413

3) I opened Reaper and loaded one instance of both Nebula versions (reverb and normal). It worked flawlessly.

4) I went back to my acustica folder and renamed them again to:

Nebula3 Reverb.dll
Nebula3 Reverb.xml
Nebula3.dll
Nebula3.xml

5) I opened Reaper again and it is still working :)

Giancarlo, this renaming issue is a real problem for most Reaper users using both 32-bits and 64-bits versions in the same machine (I use the 32-bits version for recording/mixing and the 64-bits version for producing and sometimes mixing). Is there any advantage in having different names for the 64-bits versions in other hosts?
i7 3770k :: Asus P8H77-V LE :: 16Gb DDR3 @1600MHz :: Geforce GT 520 :: OCZ-Vertex 128Gb :: WD Black Series 1Tb and Green Series 1Tb :: F*******e Liquid56 :: REAPER 64bit and StudioOne 64bit (both latest versions) :: Win 10 64bit
User avatar
Mercado_Negro
Beta Tester
Beta Tester
 
Posts: 1353
Joined: Sat Mar 27, 2010 9:30 am

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby giancarlo » Fri Jun 18, 2010 2:13 pm

well, I could release an upgrade which installs nebula using the same names used for the 32 bits version... Really it's not clear what to do here. 64 bit dll should be named differently from 32 bit dll in windows....
User avatar
giancarlo
Founder
Founder
 
Posts: 9183
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby Mercado_Negro » Sat Jun 19, 2010 10:40 pm

giancarlo wrote:well, I could release an upgrade which installs nebula using the same names used for the 32 bits version... Really it's not clear what to do here. 64 bit dll should be named differently from 32 bit dll in windows....


Not really. Many developers use the same name for both versions. It is not really a problem because 64-bit builds should go to "Program Files" and 32-bits builds should be installed in "Program Files (x86)". I got Reaper 32-bits installed in "Program Files (x86)/REAPER" and Reaper 64-bits in "Program Files/REAPER". They are two different installation paths, no problem at all with names. Actually, I think it is the best for both the end-user and the developer.
i7 3770k :: Asus P8H77-V LE :: 16Gb DDR3 @1600MHz :: Geforce GT 520 :: OCZ-Vertex 128Gb :: WD Black Series 1Tb and Green Series 1Tb :: F*******e Liquid56 :: REAPER 64bit and StudioOne 64bit (both latest versions) :: Win 10 64bit
User avatar
Mercado_Negro
Beta Tester
Beta Tester
 
Posts: 1353
Joined: Sat Mar 27, 2010 9:30 am

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby nolman » Tue Aug 24, 2010 1:38 pm

I have kind of the same problem I think:

installed upgrade and nebula3reverb works with original skin,
nebula3 doesn't, (crash in reaper with the same skin as OP).
I have no nebula3.xml file anymore and no backup.
Any suggestions?

edit:
as i understand i can copy te reverb xml and rename to nebula3.xml
and adjust the settings in the gui?
nolman
User Level 0
User Level 0
 
Posts: 1
Joined: Mon Apr 26, 2010 9:51 am

Re: Nebula 1.3.412 (64-bits version): Initialization fails

Postby giancarlo » Tue Aug 24, 2010 2:20 pm

no, the xml should not be copied. Only dll are the same executable, xml for nebula3 and nebula3 reverb are different. I suggest to install "setup nebula3", than your personal key again, tell me if it works. Next week I'll upload new versions, I think many bugs are fixed now.
User avatar
giancarlo
Founder
Founder
 
Posts: 9183
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest