Login

Nebula 3 Pro GUI 4 in Snow Leopard / older OSX

Tips & tricks, working results, technical support

Nebula 3 Pro GUI 4 in Snow Leopard / older OSX

Postby atticmike » Fri Nov 27, 2015 6:50 pm

In the installation.txt it says: Due the constants change in lasted version of OSX, our current UI framework, VSTGUI4 framework, will not work in legacy OSX version like OSX 10.6. If you are using OSX 10.6 or OSX 10.7 we recommend you to install setup marked as VSTGUI3.

I'm running 10.6.8 and installed GUI4 and it works. Does it mean I can keep it that way? Wasn't it supposed to work but it did in my case? Or are there unforseen things within the operation that I can't see?
atticmike
User Level 0
User Level 0
 
Posts: 4
Joined: Thu Aug 15, 2013 6:11 pm

Re: Nebula 3 Pro GUI 4 in Snow Leopard / older OSX

Postby Support » Fri Nov 27, 2015 7:11 pm

When VSTGUI3 or VSTGUI4 not works depends on factors that can not can not be seen at user level. We already switch to a better framework called JUCE. AU JUCE we will release very soon.

If VSTGUI4 UI framework works in your computer use it, if not, try VSTGUI3, if also not work contact us in a support ticket for a public preview of AU JUCE.

https://en.wikipedia.org/wiki/Cocoa_%28API%29
https://en.wikipedia.org/wiki/JUCE
Best regards,
Enrique Silveti.
Acustica Audio customer and technical support
http://www.acustica-audio.com
User avatar
Support
Expert
Expert
 
Posts: 2877
Joined: Mon Feb 24, 2014 11:33 am
Location: Lodi, Lombardia, Italy.

Re: Nebula 3 Pro GUI 4 in Snow Leopard / older OSX

Postby mathias » Fri Nov 27, 2015 9:51 pm

atticmike wrote:In the installation.txt it says: Due the constants change in lasted version of OSX, our current UI framework, VSTGUI4 framework, will not work in legacy OSX version like OSX 10.6. If you are using OSX 10.6 or OSX 10.7 we recommend you to install setup marked as VSTGUI3.

I'm running 10.6.8 and installed GUI4 and it works. Does it mean I can keep it that way? Wasn't it supposed to work but it did in my case? Or are there unforseen things within the operation that I can't see?


if it works, just use it.
back when i worked in snow leopard, vstgui4 worked great. sometimes it depends on the graphic card in use by the system.
system 1: windows 8 32 bit - samplitude prox, tracktion6, reaper
system 2: mac osx yosemite - reaper(32+64bit), tracktion6(32+64bit)

both systems on: macbook pro (late 2009), core 2 duo 3,06 ghz, 4 gb ram, graphic: nvidia geforce 9600M GT 512 MB
mathias
Expert
Expert
 
Posts: 2114
Joined: Wed Mar 31, 2010 12:25 am
Location: South-West Germany


Return to Working with Nebula

Who is online

Users browsing this forum: No registered users and 3 guests