You still have something that requires 1.x? Most of the stuff I know of is 2.0+.
DotNet 2.0 and up is 'the same thing', as in, DotNet framework 3.5 is a replacement for 2.0... but 1.1 is still it's old same self, and if a program requires 1.x, you need to install it even if you have 2.0 or higher already installed.
That being said, the installer had issues thinking it doesn't need to install / update since it sees a higher dotnet framework already installed. The official microsoft way to fix this issue is to manually uninstall all DotNet frameworks you have installed, and then manually install the two latest you need (1.1 and the real latest, which is 4.x by now?).