Login

Vanishing Libraries

Tips & tricks, working results, technical support

Re: Vanishing Libraries

Postby richie43 » Mon Jul 22, 2013 10:04 am

enriquesilveti wrote:Remove all libraries, less the problematic one, also AA library less your INIT files. Delete temp files and scanboot file. Add LOG and send me your log, computer information, and problematic library information to me AA email.

viewtopic.php?f=7&t=369

Thanks Enrique. It may take me a few days to get this to you, but I am very curious. Thanks for stepping in.
The Sounds of the Hear and Now
http://soundyaudio.com/
richie43
Expert
Expert
 
Posts: 4859
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA

Re: Vanishing Libraries

Postby zabukowski » Mon Jul 22, 2013 12:27 pm

I think the problem always arises when exceeding cca. 9800 programs, no matter which library.

Zabukowski
User avatar
zabukowski
Expert
Expert
 
Posts: 1103
Joined: Sun Mar 28, 2010 8:44 pm
Location: Ljubljana, Slovenia

Re: Vanishing Libraries

Postby richie43 » Mon Jul 22, 2013 5:03 pm

zabukowski wrote:I think the problem always arises when exceeding cca. 9800 programs, no matter which library.

Zabukowski


That's what I thought, but I just installed an ENORMOUS library I am testing for a Nebula developer, and it appears just fine. And with my already close to max preset count, this library alone (only 1 sample rate) adds over 1000 presets, which should totally top it off, but they appear. Either way, I am assuming that it is due to my huge numbers....
The Sounds of the Hear and Now
http://soundyaudio.com/
richie43
Expert
Expert
 
Posts: 4859
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA

Re: Vanishing Libraries

Postby enriquesilveti » Mon Jul 22, 2013 5:21 pm

I think 0-200 banks are reserved so something similar that is way maximum is 9800 and not 10.000.
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Expert
Expert
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Re: Vanishing Libraries

Postby richie43 » Mon Jul 22, 2013 5:30 pm

enriquesilveti wrote:I think 0-200 banks are reserved so something similar that is way maximum is 9800 and not 10.000.


That probably explains me whole issue then. I think I need an intervention..... :?
The Sounds of the Hear and Now
http://soundyaudio.com/
richie43
Expert
Expert
 
Posts: 4859
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA

Re: Vanishing Libraries

Postby Cupwise » Mon Jul 22, 2013 7:51 pm

but if you have different nebula.dll and .xml files, wouldn't they have their own counts for the libraries? if you had more than one nebula install, and they used different config xmls, how would they know the other exists? i don't see why you couldn't get around that limit without too much trouble..
Cupwise
Expert
Expert
 
Posts: 773
Joined: Tue Nov 23, 2010 2:03 am

Re: Vanishing Libraries

Postby richie43 » Mon Jul 22, 2013 8:30 pm

Cupwise wrote:but if you have different nebula.dll and .xml files, wouldn't they have their own counts for the libraries? if you had more than one nebula install, and they used different config xmls, how would they know the other exists? i don't see why you couldn't get around that limit without too much trouble..


That is exactly what I was hoping. The different dll's and xml's still use the main repository as reference, so maybe that total count still matters. But since you have chimed in Tim.....
I need to say that some libraries are still being seen by Nebula for me, even with the super high number of presets. So there is something there in the naming (I am guessing) or in the presets themselves that allow some to get around this and others not to. I am currently testing another new library for another developer, and if I were to install all of the sample rates and options, that library alone is over the Nebula limit by itself. I installed only one sample rate, but that is close to 4000 presets for now, so that would definitely put me over this limit. But I am able to see it in Nebula and Nebula Setups and make the customized dll. For whatever reason, I still can not see the Yourei update of yours without using an alternativedatapath. So part of my issue is this documented limits of Nebula, maybe, but there seems to be something about specific libraries that affect the outcome.
The Sounds of the Hear and Now
http://soundyaudio.com/
richie43
Expert
Expert
 
Posts: 4859
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA

Re: Vanishing Libraries

Postby richie43 » Mon Jul 22, 2013 11:55 pm

enriquesilveti wrote:Remove all libraries, less the problematic one, also AA library less your INIT files. Delete temp files and scanboot file. Add LOG and send me your log, computer information, and problematic library information to me AA email.

viewtopic.php?f=7&t=369


I am a little unclear about what you are asking me to do...
remove everything from my nebulatemprepository folder except for problematic library and the 2 init files in the programs and vectors folders? Do you want the rest of the repository contents, like the discretionary, temp folder (empty), etc. I guess I am asking if you want the folder structure of the repository, just empty....? What am I missing here?
The Sounds of the Hear and Now
http://soundyaudio.com/
richie43
Expert
Expert
 
Posts: 4859
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA

Re: Vanishing Libraries

Postby enriquesilveti » Tue Jul 23, 2013 11:01 am

OK I understand. You should use different alternativedatapath for each extra Nebula setup.
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Expert
Expert
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Re: Vanishing Libraries

Postby richie43 » Tue Jul 23, 2013 4:20 pm

enriquesilveti wrote:OK I understand. You should use different alternativedatapath for each extra Nebula setup.

I tried that with a few recently but one didn't work. Maybe I am not sure how to set that up properly. I know about adding the "alternativedatapath" location in the xml, after datapath. That points to the new location. But does it then also need a setup file in the setup folder? Does it need anything else other than the one altered xml? Thanks Enrique.
By the way, I removed many libraries from my temprepository folder, and the one library that originally inspired this thread is still not appearing, even though my count is below the supposed threshold.
The Sounds of the Hear and Now
http://soundyaudio.com/
richie43
Expert
Expert
 
Posts: 4859
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA

PreviousNext

Return to Working with Nebula

Who is online

Users browsing this forum: No registered users and 2 guests