Login

Moving libraries - different Server configurations

Tips & tricks, working results, technical support

Moving libraries - different Server configurations

Postby dream » Fri Apr 05, 2013 6:09 am

I was trying to move Nebula libraries on separate folders. The idea was to organize them for 3rd party developer: now my Vector folder has 200 GB and the time to open a project is very slow, more than 5 minutes.

Of course if I'll delete the old library I won't be able to open old projects and that's fine with me.
This system works fine with Nebula Pro, I've made a copy of the vst plugin, changed the alternative data path, copied all the authorizations and deleted the content inside the copied Temp folder. It works and the loading time is incredibly fast! Probably it's the same amount of time when I installed Nebula for the first time, but you don't realize your beard is longer than the day before. :D

My question is: What about Nebula Server? Can we still use this configuration? Or I should give up this idea with Nebula Server and give in to the huge loading time?


My configuration:

Computer: MacBookPro - half 2010, i7 2.66 Ghz, 4 GB RAM, OS X 10.8.3 -
Nebula version: Pro. and Server v 1.3.502
Daw: Cubase 7.0.3
Mixing Engineer | Producer | Editing Audio Expert
http://www.davidefant.com
User avatar
dream
Member
Member
 
Posts: 231
Joined: Thu May 27, 2010 7:23 pm
Location: Los Angeles / Italy (Belluno)

Re: Moving libraries - different Server configurations

Postby enriquesilveti » Fri Apr 05, 2013 9:38 am

Depends on several factors. Same HDD but different partition? You should have the same loading times in Nebul3 PRO and Server. Please send me your .XML MAST file. I'll review. Which version of Nebul3 PRO Server are you using? enrique.silveti AT acusticaudio.net
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Global Moderator
Global Moderator
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Re: Moving libraries - different Server configurations

Postby dream » Sat Apr 06, 2013 1:27 am

Thanks Enrique!

My bad, I didn't explain myself clearly. :)

The loading time is the same in both version Pro and Server.
I've talked about the loading time only to express the necessity to create different configurations (=different Nebula vst copies), indeed different Nebula configurations allow me to split up my library in smaller parts and hugely reduce the loading time.

This system works totally fine with Nebula Pro. My problem is that i don't know (since I've tried without succeed) how to create different configurations with Nebula Server.

Of course I tried to load Nebula Server with the new configuration but it doesn't work. By the way, I'm testing this system just with few programs.

If you thinks you still need my xml file let me know, thanks so much for your help!

PS: the Server Version is NebulaServerMac x64 1.3.502. I do not have any program and vector on Macintosh HD (only INIT), all my libraries are on an external HD which is divided in 3 partitions, but all programs and vectors are in the same partition.
Mixing Engineer | Producer | Editing Audio Expert
http://www.davidefant.com
User avatar
dream
Member
Member
 
Posts: 231
Joined: Thu May 27, 2010 7:23 pm
Location: Los Angeles / Italy (Belluno)

Re: Moving libraries - different Server configurations

Postby enriquesilveti » Sun Apr 07, 2013 9:53 am

dream wrote:Thanks Enrique!

My bad, I didn't explain myself clearly. :)

The loading time is the same in both version Pro and Server.
I've talked about the loading time only to express the necessity to create different configurations (=different Nebula vst copies), indeed different Nebula configurations allow me to split up my library in smaller parts and hugely reduce the loading time.

This system works totally fine with Nebula Pro. My problem is that i don't know (since I've tried without succeed) how to create different configurations with Nebula Server.

Of course I tried to load Nebula Server with the new configuration but it doesn't work. By the way, I'm testing this system just with few programs.

If you thinks you still need my xml file let me know, thanks so much for your help!

PS: the Server Version is NebulaServerMac x64 1.3.502. I do not have any program and vector on Macintosh HD (only INIT), all my libraries are on an external HD which is divided in 3 partitions, but all programs and vectors are in the same partition.


Nebula3 PRO Server works almost equal than Nebula3 PRO if don't detect a Nebula Server stand alone application running in the local or LAN computers, we call Nebula local mode.
Due you are under OSX you can not use a fake folder in installation. Move your Nebula3 PRO Server .DLL files to a backup folder. Re install Nebula3 PRO and create your Nebula alias with custom emulation presets to load. Then overwrite Nebula3 PRO with Nebula3 PRO Server .DLL. Everything should work as with Nebula3 PRO but you will have better RAM performance due Nebula3 PRO Server is based into Core3.


You can back to Nebula3 PRO configuration, then use a fake destination folder to get Nebula3 PRO Server
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Global Moderator
Global Moderator
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Re: Moving libraries - different Server configurations

Postby dream » Mon Apr 08, 2013 1:38 am

enriquesilveti wrote:Nebula3 PRO Server works almost equal than Nebula3 PRO if don't detect a Nebula Server stand alone application running in the local or LAN computers, we call Nebula local mode.
Due you are under OSX you can not use a fake folder in installation. Move your Nebula3 PRO Server .DLL files to a backup folder. Re install Nebula3 PRO and create your Nebula alias with custom emulation presets to load. Then overwrite Nebula3 PRO with Nebula3 PRO Server .DLL. Everything should work as with Nebula3 PRO but you will have better RAM performance due Nebula3 PRO Server is based into Core3.


You can back to Nebula3 PRO configuration, then use a fake destination folder to get Nebula3 PRO Server


I'm aware about this terminology, I remember I was running Nebula in both local server mode and in a real server configuration with 3 computers in the system, and with cuda too under 10.6.8. It was pretty amazing. :)

Anyway, I've tried to follow your instructions but as soon as I re-install Nebula (doesn't matter if Pro or Server), Cubase does not detect the plugin anymore.

Just to let you know I'm not able to find the "Nebula Server .dll" in my system (I should call it .vst since I'm on OSX).

So here how I did. Tell me if this make sense for you and if I'm correct.
1. I downloaded from my User Area this file: Nebula VST no installers 1.3.505 (x86/x64).zip;
2. I replaced the Nebula Pro .vst with the Server .vst version just downloaded;
3. I made all the .vst copies with custom presets from the Server .vst version.

Before all this process I was running Nebula Pro 1.3.502 and now on the master page when I load Nebula it tells me version 1.3.505 (without launch the Server application, if I do that the version is still 1.3.502) so I guess I'm running the Server now.

It works. I'm just wondering if I'm running Nebula server in local mode or not. Can you confirm it?

Here a couple of screenshot:
custom Neb preset
Neb MAST page

In this way I don't even get problems with both AITB and AcusticaAudio auth. I've talked about that in this thread.
Mixing Engineer | Producer | Editing Audio Expert
http://www.davidefant.com
User avatar
dream
Member
Member
 
Posts: 231
Joined: Thu May 27, 2010 7:23 pm
Location: Los Angeles / Italy (Belluno)

Re: Moving libraries - different Server configurations

Postby enriquesilveti » Mon Apr 08, 2013 12:04 pm

Go DISK and see under Server parameter. You should run manually Server stand alone application before run sequencer to force Nebula Client to be loaded thru local server.
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Global Moderator
Global Moderator
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Re: Moving libraries - different Server configurations

Postby dream » Tue Apr 09, 2013 12:51 am

I thought to replace the NebulaServer vst was a way to force Nebula to the local mode. My bad.

Anyway, with the new configuration I've tried to do as usual: I run the server application before load Cubase and than I launch Nebula.

The server loads instances with no problems.
Here the Disk Page.

All the 3rd party libraries work fine, AlexB, CdSoundMaster, Ownhammer, Cupwise, HernyHolonga, rhythminmind but AITB and AcusticaAudio give me the INIT preset. Actually I had this problem before all this new moving libraries thing.
So if according with the pictures I've linked you think the Server is running correctly can we try to solve this auth issue?
Mixing Engineer | Producer | Editing Audio Expert
http://www.davidefant.com
User avatar
dream
Member
Member
 
Posts: 231
Joined: Thu May 27, 2010 7:23 pm
Location: Los Angeles / Italy (Belluno)

Re: Moving libraries - different Server configurations

Postby enriquesilveti » Tue Apr 09, 2013 10:45 am

Upload here you .XML mast page.
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Global Moderator
Global Moderator
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Re: Moving libraries - different Server configurations

Postby dream » Tue Apr 09, 2013 11:01 pm

Here we go. :)

Nebula3 Reverb.xml.zip
file path: /Library/Audio/Plug-Ins/VST/Acustica
(1.39 KiB) Downloaded 29 times
Attachments
NebulaServerMac.xml.zip
file path: /Library/Audio/Presets/AcusticaAudio/Nebula3/Server
(1.44 KiB) Downloaded 22 times
Mixing Engineer | Producer | Editing Audio Expert
http://www.davidefant.com
User avatar
dream
Member
Member
 
Posts: 231
Joined: Thu May 27, 2010 7:23 pm
Location: Los Angeles / Italy (Belluno)

Re: Moving libraries - different Server configurations

Postby enriquesilveti » Wed Apr 10, 2013 1:51 pm

No Server tags in client MAST page! Add in Nebula3 Reverb.xml:

Code: Select all
<SERVERADDRESS> 127.0.0.1 </SERVERADDRESS>
<SERVERPORT> 6000 </SERVERPORT>
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SDD)
SP4 (i5-6300 | 8 GB | 256 SDD)
RME UFX | PS Lyra2 | SD USBPre2
VM U15 | VM W10 | VM OSX 10.12
N4/NAT4 | SPX3 | RX5 | LN2C | Smaart8 | R5 | PT12 | PX10
User avatar
enriquesilveti
Global Moderator
Global Moderator
 
Posts: 2662
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires

Next

Return to Working with Nebula

Who is online

Users browsing this forum: No registered users and 4 guests