Login

Reaper CUDA issue, can't find cudart_32_40_17.dll

Tips & tricks, working results, technical support

Reaper CUDA issue, can't find cudart_32_40_17.dll

Postby Jedison » Tue Jun 07, 2011 5:36 am

Hey all I'm loving Nebula, but I'm basically at my wits end...

Here's my setup:
Win7 64bit
Reaper 32bit
Nebula 32bit
CUDABridge for 32bit
32bit Cuda Toolkit
Latest NVIDIA drivers, Geforce GTX 460

I install the 32bit toolkit using the typical settings into the directory:
C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.0\

And I put WheresMyCuda, CudaTest in the folder:
C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.0\bin

where cudart32_40_17.dll is located. When I run it finds it no problems. The problem is that when I load up Reaper I get a reaper.exe - System Error:
"The program can't start because cudart32_40_17.dll is missing from your computer. Try reinstalling the program to fix this problem."

No idea why this occurs, and I've installed everything in the right order and UAC is disabled. Any help would be extremely appreciated, so I can get back to busiiness. Thanks everyone!
Jedison
User Level 0
User Level 0
 
Posts: 2
Joined: Thu Jun 02, 2011 3:05 am

Re: Reaper CUDA issue, can't find cudart_32_40_17.dll

Postby micstandbob » Tue Jun 07, 2011 7:51 am

had the exact same problem just now with the 64bit version asking for cudart_64_40_17.... i restarted the computer and where is my cuda runs successfully now!
micstandbob
User Level II
User Level II
 
Posts: 22
Joined: Wed Apr 07, 2010 4:54 am

Re: Reaper CUDA issue, can't find cudart_32_40_17.dll

Postby giancarlo » Tue Jun 07, 2011 10:07 am

we updated a new version of cudabridge
User avatar
giancarlo
Founder
Founder
 
Posts: 9195
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Reaper CUDA issue, can't find cudart_32_40_17.dll

Postby Jedison » Tue Jun 07, 2011 5:23 pm

Thanks for the help everyone, I am using the latest Cuda bridge. Apparently it seems to be working however, is there a way to truly if it's running off GPU? I don't notice any cpu decrease when using the CUDA dll, and performance still seems to be loads better if I use the regular Nebula dll on EQ's etc, so maybe I'm missing the point? I seem to think it's not actually offloading work to the GPU, as it's my understanding the NebulaCUDA.dll can run EQ's, Compressors and all that as well as Reverbs?

Also the reverb or cuda dll's also give me a horrible clipping aliased sound when I run any library on it (including reverb). Any ideas? Thanks again.
Jedison
User Level 0
User Level 0
 
Posts: 2
Joined: Thu Jun 02, 2011 3:05 am

Re: Reaper CUDA issue, can't find cudart_32_40_17.dll

Postby giancarlo » Tue Jun 07, 2011 7:54 pm

mmmh the aliasing is strange. Are you using mode 15? Tuning a nebula3 reverb, right? otherwise it would simply crash.
Test a reverb before, a long tailed one. Tell me if you see a GPU utilization in DISK page of nebula, and how much. And which is CPU usage in PROG page of nebula.
User avatar
giancarlo
Founder
Founder
 
Posts: 9195
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy


Return to Working with Nebula

Who is online

Users browsing this forum: No registered users and 6 guests